Back to: Opinion
October 2, 2013
Follow Opinion

Can’t afford “Affordable Care Act”

My Medicare “bullet proof vest” is costing me twice, yes, twice as much next year. So, Bill Trzeciak, although your recent letter to the editor intended to calm us old folks down, it did not work with me. I am angry. I want my insurance back as it was. Obamacare costs are horrifying. Both of my supplemental insurance companies assured me that their new higher premiums were not a result of my age (72), nor my excellent health. They said that they needed to raise all premiums for everybody to “comply with The Affordable Care Act.” OK, now I am paying for the really sick and the close of their donut hole. I don’t know about the rest of us old folks, but I cannot afford this so called Affordable Care Act.

Toni Laub

Grass Valley


Explore Related Articles

Trending in: Opinion

Trending Sitewide

The Union Updated Oct 2, 2013 12:14AM Published Oct 2, 2013 12:14AM Copyright 2013 The Union. All rights reserved. This material may not be published, broadcast, rewritten or redistributed.